const regex = /(_\w+)\1+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(_\\w+)\\1+', 'gm')
const str = `proba_m4050_434_3g3_3g3.png
proba_m313_313.png
proba_m5214_2520_gb54_gb54.png
proba_m5214_2520_gb54_gb54_gb54.png
proba_m141_18d5_fd071_fd071.png
proba_m312_534_430_39g.png
proba_m3501_5721.png`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);