import re
regex = re.compile(r"(_\w+)\1+", flags=re.MULTILINE)
test_str = ("proba_m4050_434_3g3_3g3.png\n"
"proba_m313_313.png\n"
"proba_m5214_2520_gb54_gb54.png\n"
"proba_m5214_2520_gb54_gb54_gb54.png\n"
"proba_m141_18d5_fd071_fd071.png\n"
"proba_m312_534_430_39g.png\n"
"proba_m3501_5721.png")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)