# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\n\s{8,}(.*))|(?:\n\s{6,}(]|}))/\1\2/mg;t' <<< "{
\"layer1\": {
\"layer2\": {
\"layer3_1\": [
{
\"x\": 1,
\"y\": 7
},
{
\"x\": 0,
\"y\": 4
},
{
\"x\": 5,
\"y\": 3
},
{
\"x\": 6,
\"y\": 9
}
],
\"layer3_2\": \"string\"
}
}
}"