re = /(?:\n\s{8,}(.*))|(?:\n\s{6,}(]|}))/m
str = '{
"layer1": {
"layer2": {
"layer3_1": [
{
"x": 1,
"y": 7
},
{
"x": 0,
"y": 4
},
{
"x": 5,
"y": 3
},
{
"x": 6,
"y": 9
}
],
"layer3_2": "string"
}
}
}'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result