// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\n\s{8,}(.*))|(?:\n\s{6,}(]|}))").unwrap();
let string = "{
\"layer1\": {
\"layer2\": {
\"layer3_1\": [
{
\"x\": 1,
\"y\": 7
},
{
\"x\": 0,
\"y\": 4
},
{
\"x\": 5,
\"y\": 3
},
{
\"x\": 6,
\"y\": 9
}
],
\"layer3_2\": \"string\"
}
}
}";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}