# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\n\s{8,}(.*))|(?:\n\s{6,}(]|}))"
test_str = ("{\n"
" \"layer1\": {\n"
" \"layer2\": {\n"
" \"layer3_1\": [\n"
" {\n"
" \"x\": 1,\n"
" \"y\": 7\n"
" },\n"
" {\n"
" \"x\": 0,\n"
" \"y\": 4\n"
" },\n"
" {\n"
" \"x\": 5,\n"
" \"y\": 3\n"
" },\n"
" {\n"
" \"x\": 6,\n"
" \"y\": 9\n"
" }\n"
" ],\n"
" \"layer3_2\": \"string\"\n"
" }\n"
" }\n"
"}")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.