package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\n\s{8,}(.*))|(?:\n\s{6,}(]|}))`)
var str = `{
"layer1": {
"layer2": {
"layer3_1": [
{
"x": 1,
"y": 7
},
{
"x": 0,
"y": 4
},
{
"x": 5,
"y": 3
},
{
"x": 6,
"y": 9
}
],
"layer3_2": "string"
}
}
}`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}