#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(?:[cC]:[/\\])?(?:\w+[/\\])*\w+\.[a-z]+"
Local $sString = "C:\Users\esteban\Desktop\Java_file_testing\file3.txt" & @CRLF & _
"Users/bar.txt" & @CRLF & _
"c:/users/foo.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")