using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:[cC]:[/\\])?(?:\w+[/\\])*\w+\.[a-z]+";
string input = @"C:\Users\esteban\Desktop\Java_file_testing\file3.txt
Users/bar.txt
c:/users/foo.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}