re = /\s*(?:[cC]:[\/\\])?(?:\w+[\/\\])*\w+\.[a-z]+/
str = 'C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
Users/bar.txt
c:/users/foo.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end