$re = '~\s*(?:[cC]:[/\\\\])?(?:\w+[/\\\\])*\w+\.[a-z]+~';
$str = 'C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
Users/bar.txt
c:/users/foo.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);