import re
regex = re.compile(r"\s*(?:[cC]:[/\\])?(?:\w+[/\\])*\w+\.[a-z]+")
test_str = ("C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt\n"
"Users/bar.txt\n"
"c:/users/foo.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")