using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([\""\'])|(\()|(\[)).+?(?(1)\1|(?(2)\)|\]))";
string input = @"[2016-04-25 03:48:34] (info) (info) (info) (info) (info) (info) (info) ""Tough times""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}