import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([\\\"\\'])|(\\()|(\\[)).+?(?(1)\\1|(?(2)\\)|\\]))";
final String string = "[2016-04-25 03:48:34] (info) (info) (info) (info) (info) (info) (info) \"Tough times\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}