$re = '/(?:([\"\'])|(\()|(\[)).+?(?(1)\1|(?(2)\)|\]))/';
$str = '[2016-04-25 03:48:34] (info) (info) (info) (info) (info) (info) (info) "Tough times"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);