import re
regex = re.compile(r"(?:([\"\'])|(\()|(\[)).+?(?(1)\1|(?(2)\)|\]))")
test_str = "[2016-04-25 03:48:34] (info) (info) (info) (info) (info) (info) (info) \"Tough times\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")