re = /(?:([\"\'])|(\()|(\[)).+?(?(1)\1|(?(2)\)|\]))/
str = '[2016-04-25 03:48:34] (info) (info) (info) (info) (info) (info) (info) "Tough times"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end