use strict;
my $str = '<p> </p>';
my $regex = qr/<p>\s*<\/p>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";