import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\\.?\\-?[A-Za-zÀ-ÖØ-öø-ÿ]+";
final String string = "fiji\n"
+ "new-caledonia \n"
+ "saint-lucia \n"
+ "st.-vincent-grenadines \n"
+ "curaçao \n"
+ "saint-kitts-and-nevis \n"
+ "falkland-islands";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}