const regex = /(\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\.?\-?[A-Za-zÀ-ÖØ-öø-ÿ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\\.?\\-?[A-Za-zÀ-ÖØ-öø-ÿ]+', 'gm')
const str = `fiji
new-caledonia
saint-lucia
st.-vincent-grenadines
curaçao
saint-kitts-and-nevis
falkland-islands`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}