$re = '/(\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\.?\-?[A-Za-zÀ-ÖØ-öø-ÿ]+/m';
$str = 'fiji
new-caledonia
saint-lucia
st.-vincent-grenadines
curaçao
saint-kitts-and-nevis
falkland-islands';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);