re = /(\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\.?\-?[A-Za-zÀ-ÖØ-öø-ÿ]+/m
str = 'fiji
new-caledonia
saint-lucia
st.-vincent-grenadines
curaçao
saint-kitts-and-nevis
falkland-islands'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end