using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[0-9]+ )?\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*";
string input = @"2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}