package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:[0-9]+ )?\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*`)
var str = `2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}