const regex = /(?:[0-9]+ )?\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[0-9]+ )?\\(*([a-z]+[₀-₉]*)+\\)*[₀-₉]*', 'gi')
const str = `2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}