import re
regex = re.compile(r"(?:[0-9]+ )?\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*", flags=re.IGNORECASE)
test_str = "2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")