import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)$\\s+?^(?=.*^\\1$)\n";
final String string = "FCS-S-101 (One Slat Asymmetry)\n"
+ "FCS-S-101 (One Slat Asymmetry)\n"
+ "FCS-S-101 (One Slat Asymmetry)\n"
+ "FCS-S-103 (One Slat Skew)\n"
+ "FCS-S-103 (One Slat Skew)\n"
+ "FCS-S-103 (One Slat Skew)\n"
+ "FCS-S-68 (Uncommanded Flaps Movement)\n"
+ "FCS-S-68 (Uncommanded Flaps Movement)\n"
+ "FCS-S-68 (Uncommanded Flaps Movement)\n"
+ "FCS-S-68 (Uncommanded Flaps Movement)\n"
+ "FCS-S-68 (Uncommanded Flaps Movement)\n"
+ "FCS-S-70 (Flaps Jammed, Unannunciated)\n"
+ "FCS-S-70 (Flaps Jammed, Unannunciated)\n"
+ "FCS-S-70 (Flaps Jammed, Unannunciated)\n"
+ "FCS-S-70 (Flaps Jammed, Unannunciated)\n"
+ "FCS-S-70 (Flaps Jammed, Unannunciated)\n"
+ "FCS-S-75 (Erroneous Flaps Indication)\n"
+ "FCS-S-75 (Erroneous Flaps Indication)\n"
+ "FCS-S-79 (Flaps Asymmetry)\n"
+ "FCS-S-79 (Flaps Asymmetry)\n"
+ "FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)\n"
+ "FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)\n"
+ "FCS-S-84 / FCS-S-86 (Inboard / Outboard flap Skew)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-89 (Uncommanded Slats Movement)\n"
+ "FCS-S-91 (Slats Jammed, Unannunciated)\n"
+ "FCS-S-91 (Slats Jammed, Unannunciated)\n"
+ "FCS-S-91 (Slats Jammed, Unannunciated)\n"
+ "FCS-S-91 (Slats Jammed, Unannunciated)\n"
+ "FCS-S-95 (Erroneous Slats Indication)\n"
+ "FCS-S-95 (Erroneous Slats Indication)\n"
+ "FCS-S-95 (Erroneous Slats Indication)\n"
+ "FCS-S-95 (Erroneous Slats Indication)\n"
+ "FCS-S-99 (Slats Asymmetry)\n"
+ "FCS-S-99 (Slats Asymmetry)\n"
+ "FCS-S-99 (Slats Asymmetry)\n"
+ "FCS-S-99 (Slats Asymmetry)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}