import Foundation
let pattern = #"""
^(.*?)$\s+?^(?=.*^\1$)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
FCS-S-101 (One Slat Asymmetry)
FCS-S-101 (One Slat Asymmetry)
FCS-S-101 (One Slat Asymmetry)
FCS-S-103 (One Slat Skew)
FCS-S-103 (One Slat Skew)
FCS-S-103 (One Slat Skew)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-75 (Erroneous Flaps Indication)
FCS-S-75 (Erroneous Flaps Indication)
FCS-S-79 (Flaps Asymmetry)
FCS-S-79 (Flaps Asymmetry)
FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)
FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)
FCS-S-84 / FCS-S-86 (Inboard / Outboard flap Skew)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)