import re
regex = re.compile((r"^(.*?)$\s+?^(?=.*^\1$)\n"), flags=re.MULTILINE | re.DOTALL)
test_str = ("FCS-S-101 (One Slat Asymmetry)\n"
"FCS-S-101 (One Slat Asymmetry)\n"
"FCS-S-101 (One Slat Asymmetry)\n"
"FCS-S-103 (One Slat Skew)\n"
"FCS-S-103 (One Slat Skew)\n"
"FCS-S-103 (One Slat Skew)\n"
"FCS-S-68 (Uncommanded Flaps Movement)\n"
"FCS-S-68 (Uncommanded Flaps Movement)\n"
"FCS-S-68 (Uncommanded Flaps Movement)\n"
"FCS-S-68 (Uncommanded Flaps Movement)\n"
"FCS-S-68 (Uncommanded Flaps Movement)\n"
"FCS-S-70 (Flaps Jammed, Unannunciated)\n"
"FCS-S-70 (Flaps Jammed, Unannunciated)\n"
"FCS-S-70 (Flaps Jammed, Unannunciated)\n"
"FCS-S-70 (Flaps Jammed, Unannunciated)\n"
"FCS-S-70 (Flaps Jammed, Unannunciated)\n"
"FCS-S-75 (Erroneous Flaps Indication)\n"
"FCS-S-75 (Erroneous Flaps Indication)\n"
"FCS-S-79 (Flaps Asymmetry)\n"
"FCS-S-79 (Flaps Asymmetry)\n"
"FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)\n"
"FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)\n"
"FCS-S-84 / FCS-S-86 (Inboard / Outboard flap Skew)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-89 (Uncommanded Slats Movement)\n"
"FCS-S-91 (Slats Jammed, Unannunciated)\n"
"FCS-S-91 (Slats Jammed, Unannunciated)\n"
"FCS-S-91 (Slats Jammed, Unannunciated)\n"
"FCS-S-91 (Slats Jammed, Unannunciated)\n"
"FCS-S-95 (Erroneous Slats Indication)\n"
"FCS-S-95 (Erroneous Slats Indication)\n"
"FCS-S-95 (Erroneous Slats Indication)\n"
"FCS-S-95 (Erroneous Slats Indication)\n"
"FCS-S-99 (Slats Asymmetry)\n"
"FCS-S-99 (Slats Asymmetry)\n"
"FCS-S-99 (Slats Asymmetry)\n"
"FCS-S-99 (Slats Asymmetry)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")