use strict;
my $str = 'FCS-S-101 (One Slat Asymmetry)
FCS-S-101 (One Slat Asymmetry)
FCS-S-101 (One Slat Asymmetry)
FCS-S-103 (One Slat Skew)
FCS-S-103 (One Slat Skew)
FCS-S-103 (One Slat Skew)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-68 (Uncommanded Flaps Movement)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-70 (Flaps Jammed, Unannunciated)
FCS-S-75 (Erroneous Flaps Indication)
FCS-S-75 (Erroneous Flaps Indication)
FCS-S-79 (Flaps Asymmetry)
FCS-S-79 (Flaps Asymmetry)
FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)
FCS-S-82 / FCS-S-87 (Outboard / Inboard Flap Asymmetry)
FCS-S-84 / FCS-S-86 (Inboard / Outboard flap Skew)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-89 (Uncommanded Slats Movement)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-91 (Slats Jammed, Unannunciated)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-95 (Erroneous Slats Indication)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)
FCS-S-99 (Slats Asymmetry)';
my $regex = qr/^(.*?)$\s+?^(?=.*^\1$)
/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}