import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "value:=This[\\s\\S]*";
final String string = "value:=This customer has one or more active tax exemptions available\\.\n\n\n"
+ " \n\n"
+ "Do you want to apply a tax exemption to this transaction\\?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}