// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"value:=This[\s\S]*").unwrap();
let string = "value:=This customer has one or more active tax exemptions available\\.
Do you want to apply a tax exemption to this transaction\\?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}