const regex = /value:=This[\s\S]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value:=This[\\s\\S]*', 'g')
const str = `value:=This customer has one or more active tax exemptions available\\.
Do you want to apply a tax exemption to this transaction\\?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}