using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!<\S)(?!\S{11})(?!\S*berry\S)(\S+berry)(?!$)";
string input = @"Some æøåberry please - Mmmm, not Blueberyflavouredblackberry
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}