$re = '/(?!<\S)(?!\S{11})(?!\S*berry\S)(\S+berry)(?!$)/im';
$str = 'Some æøåberry please - Mmmm, not Blueberyflavouredblackberry
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);