re = /(?!<\S)(?!\S{11})(?!\S*berry\S)(\S+berry)(?!$)/im
str = 'Some æøåberry please - Mmmm, not Blueberyflavouredblackberry
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end