import re
regex = re.compile(r"(?!<\S)(?!\S{11})(?!\S*berry\S)(\S+berry)(?!$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Some æøåberry please - Mmmm, not Blueberyflavouredblackberry\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")