#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^(\d{1,2})\/(\d{4})(.*))|(^(\d{1,2})\/(\d{1,2})\/(\d{4})(.*))|(^(\d{4})\/(\d{1,2})\/(\d{1,2})(.*))"
Local $sString = "1/2016" & @CRLF & _
"1/2016 1122:344z" & @CRLF & _
"01/2016 1122:344 am" & @CRLF & _
"" & @CRLF & _
"01/02/2016 1122:344 pm" & @CRLF & _
"1/02/2016 1122:344" & @CRLF & _
"01/2/2016 1122:344" & @CRLF & _
"1/2/2016 1122:344" & @CRLF & _
"" & @CRLF & _
"2016/01/02 1122:344" & @CRLF & _
"2016/1/02 1122:344" & @CRLF & _
"2016/01/2 1122:344" & @CRLF & _
"2016/1/2 1122:344" & @CRLF & _
"" & @CRLF & _
"2016/01/27 1122:344" & @CRLF & _
"2017/01/30 1122:344" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$2/$3 $6/$8 $12/$11"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)