use strict;
my $str = '1/2016
1/2016 1122:344z
01/2016 1122:344 am
01/02/2016 1122:344 pm
1/02/2016 1122:344
01/2/2016 1122:344
1/2/2016 1122:344
2016/01/02 1122:344
2016/1/02 1122:344
2016/01/2 1122:344
2016/1/2 1122:344
2016/01/27 1122:344
2017/01/30 1122:344
';
my $regex = qr/(^(\d{1,2})\/(\d{4})(.*))|(^(\d{1,2})\/(\d{1,2})\/(\d{4})(.*))|(^(\d{4})\/(\d{1,2})\/(\d{1,2})(.*))/mp;
my $subst = '$2/$3 $6/$8 $12/$11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";