using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(\d{1,2})\/(\d{4})(.*))|(^(\d{1,2})\/(\d{1,2})\/(\d{4})(.*))|(^(\d{4})\/(\d{1,2})\/(\d{1,2})(.*))";
string substitution = @"$2/$3 $6/$8 $12/$11";
string input = @"1/2016
1/2016 1122:344z
01/2016 1122:344 am
01/02/2016 1122:344 pm
1/02/2016 1122:344
01/2/2016 1122:344
1/2/2016 1122:344
2016/01/02 1122:344
2016/1/02 1122:344
2016/01/2 1122:344
2016/1/2 1122:344
2016/01/27 1122:344
2017/01/30 1122:344
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}