import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(\\d{1,2})\\/(\\d{4})(.*))|(^(\\d{1,2})\\/(\\d{1,2})\\/(\\d{4})(.*))|(^(\\d{4})\\/(\\d{1,2})\\/(\\d{1,2})(.*))";
final String string = "1/2016\n"
+ "1/2016 1122:344z\n"
+ "01/2016 1122:344 am\n\n"
+ "01/02/2016 1122:344 pm\n"
+ "1/02/2016 1122:344\n"
+ "01/2/2016 1122:344\n"
+ "1/2/2016 1122:344\n\n"
+ "2016/01/02 1122:344\n"
+ "2016/1/02 1122:344\n"
+ "2016/01/2 1122:344\n"
+ "2016/1/2 1122:344\n\n"
+ "2016/01/27 1122:344\n"
+ "2017/01/30 1122:344\n\n";
final String subst = "$2/$3 $6/$8 $12/$11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}