import re
regex = re.compile(r"(^(\d{1,2})\/(\d{4})(.*))|(^(\d{1,2})\/(\d{1,2})\/(\d{4})(.*))|(^(\d{4})\/(\d{1,2})\/(\d{1,2})(.*))", flags=re.MULTILINE)
test_str = ("1/2016\n"
"1/2016 1122:344z\n"
"01/2016 1122:344 am\n\n"
"01/02/2016 1122:344 pm\n"
"1/02/2016 1122:344\n"
"01/2/2016 1122:344\n"
"1/2/2016 1122:344\n\n"
"2016/01/02 1122:344\n"
"2016/1/02 1122:344\n"
"2016/01/2 1122:344\n"
"2016/1/2 1122:344\n\n"
"2016/01/27 1122:344\n"
"2017/01/30 1122:344\n\n")
subst = "$2/$3 $6/$8 $12/$11"
result = regex.sub(subst, test_str)
if result:
print(result)