#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))$"
Local $sString = "2000-10-22" & @CRLF & _
"2000-10-2" & @CRLF & _
"2000-1-22" & @CRLF & _
"2000-14-22" & @CRLF & _
"2000-01-01" & @CRLF & _
"2000-01-99" & @CRLF & _
"2000-00-01" & @CRLF & _
"2000-01-00" & @CRLF & _
"0001-01-01" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")