import re
regex = re.compile(r"^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))$", flags=re.MULTILINE)
test_str = ("2000-10-22\n"
"2000-10-2\n"
"2000-1-22\n"
"2000-14-22\n"
"2000-01-01\n"
"2000-01-99\n"
"2000-00-01\n"
"2000-01-00\n"
"0001-01-01\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")