$re = '/^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))$/m';
$str = '2000-10-22
2000-10-2
2000-1-22
2000-14-22
2000-01-01
2000-01-99
2000-00-01
2000-01-00
0001-01-01
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);