// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))$").unwrap();
let string = "2000-10-22
2000-10-2
2000-1-22
2000-14-22
2000-01-01
2000-01-99
2000-00-01
2000-01-00
0001-01-01
// You can show origina post on albertcolom.com/blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}