using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\w+;)?\s*public\s+\w+\s+methodName\s*\(\)\s*$";
string input = @"Someword; public void methodName()
public void methodName()
Someword; public void; methodName();
public void methodName();";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}