re = /^(?:\w+;)?\s*public\s+\w+\s+methodName\s*\(\)\s*$/m
str = 'Someword; public void methodName()
public void methodName()
Someword; public void; methodName();
public void methodName();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end