package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w+;)?\s*public\s+\w+\s+methodName\s*\(\)\s*$`)
var str = `Someword; public void methodName()
public void methodName()
Someword; public void; methodName();
public void methodName();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}