import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<property>[\\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})";
final String string = "\n"
+ ".eight input[type='radio']:checked + label {\n"
+ " color: #888;\n"
+ " background-color: hsla(8, 8%, 8%, 0.8);\n"
+ "}\n\n"
+ ".nine {\n"
+ " background: conic-gradient(\n"
+ " #ff9 0.25turn,\n"
+ " #009 0.25turn 0.5turn,\n"
+ " #999 0.5turn 0.75turn,\n"
+ " #900 0.75turn\n"
+ " ) top left / 25% 25% repeat;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE | Pattern.UNIX_LINES);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}